Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Can't launch miot on Mac

GregShuGregShu Seattle, WA
edited October 2016 in Mongoose Binary

Mac version: 10.11.6 (15G1004)
Downloaded miot today.
When I attempt to run miot I receive the following:

dyld: Library not loaded: /usr/local/opt/libftdi/lib/libftdi1.2.dylib
Referenced from: /Users/gschu/Downloads/2016.10.12/./miot_m
Reason: image not found
Trace/BPT trap: 5

Comments

  • GregShuGregShu Seattle, WA
    edited October 2016

    Got it running. Had to install OpenOCD. Used this command as I had home-brew installed:

    brew install openocd

  • SergeySergey Dublin, Ireland
  • Hello,

    I have a similar problem. Below is the output of the installation script:

    kozmo:~ muratangi$ curl -fsSL https://mongoose-os.com/downloads/mos/install.sh | /bin/sh

    Installing libftdi1.2.dylib ...

    mkdir: /usr/local/opt/libftdi/lib: Permission denied

    curl: (23) Failed writing body (0 != 16096)

    Installing libusb-1.0.0.dylib ...

    mkdir: /usr/local/opt/libusb/lib: Permission denied

    curl: (23) Failed writing body (0 != 16094)

    Downloading https://mongoose-os.com/downloads/mos/mac/mos ...

    ################################################################## 100.0%

    Installing into /Users/muratangi/.mos/bin/mos ...

    /bin/sh: line 43: 1537 Trace/BPT trap: 5 mos --help 2> /dev/null

    SUCCESS: /Users/muratangi/.mos/bin/mos is installed.

    Run '/Users/muratangi/.mos/bin/mos --help' to see all available commands.

    Run '/Users/muratangi/.mos/bin/mos' without arguments to start a simplified Web UI

    installer.

    kozmo:~ muratangi$

    There are warning lines regarding permissions and a report line telling that installation is finished successfully.

    However, I can not run mos.
    Following is the out put of '/Users/muratangi/.mos/bin/mos'

    kozmo:~ muratangi$ /Users/muratangi/.mos/bin/mos

    dyld: Library not loaded: /usr/local/opt/libftdi/lib/libftdi1.2.dylib

    Referenced from: /Users/muratangi/.mos/bin/mos

    Reason: image not found

    Trace/BPT trap: 5

    kozmo:~ muratangi$

    Could someone guide me through?

    Sincerely,

  • SergeySergey Dublin, Ireland

    sudo chmod 777 /usr/local/opt and re-run the installer.

  • Thanks Sergey,
    I am in and happy.

  • Hi, I have the exact same problem as Muratangi it seems that a solution for him was running the " sudo chmod 777 /usr/local/opt " command that Sergey suggested. However when I run that command the terminal asks for my password and then it says "chmod: /usr/local/opt: No such file or directory" does anybody knows how to correct this? Thank you.

Sign In or Register to comment.