Copyright ©

Mongoose OS Forum


No input file specified.


Looked through the forum but couldn't find anything on this.
Using mongoose to serve PHP scripts, am having issues with the "No input file specified" pest.

I understand that, with these options
s_http_server_opts.document_root = "/serverdisk/core/site/";
s_http_server_opts.url_rewrites = ",,";

mongoose serves either of the three directories and their children

with "/serverdisk/core/site" or "/serverdisk/core/subdomain1" being set as doc_root in respective php.ini files,

php-cgi runs php in those directories

but not in their subdirectories

Tried different php.ini settings to no avail. Tried pointing the binaries to the php script files, they work.

Tried php built-in web server, werks. What I can gather is that mongoose uses the root directories and does not allow the cgi to handle anything below; even if you make php.ini configs in the subdirectories.

Tried recompiling with different combinations of paths and asterisks to no luck.
This is more likely to be a case of PEBKAC than an issue with mongoose.

What do?


Sign In or Register to comment.