Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

Cannot flash Wemos D1 mini

The following error occurs flashing a wemos d1 mini:

$ mos build --platform esp8266
Connecting to https://mongoose.cloud, user test
Uploading sources (2914 bytes)
Firmware saved to /Users/stefan/Documents/GitHub/eureka/app1/app1/build/fw.zip
Command completed.

$ mos flash
Loaded app1/esp8266 version 1.0 (20190108-151304)
Opening /dev/cu.usbserial-1440 @ 115200...
Connecting to ESP8266 ROM, attempt 1 of 10...
Connected, chip: ESP8266EX
Running flasher @ 0...
Flasher is running
Error: /Users/mos/tmp/mos_gopath/src/cesanta.com/mos/flash/esp/flasher/flasher_client.go:176: failed to read chip id (0 is not a valid id)
/Users/mos/tmp/mos_gopath/src/cesanta.com/mos/flash/esp/flasher/common.go:93: failed to get flash chip id
/Users/mos/tmp/mos_gopath/src/cesanta.com/mos/flash/esp/flasher/common.go:69: flash size is not specified and could not be detected
/Users/mos/tmp/mos_gopath/src/cesanta.com/mos/flash/esp/flasher/flash.go:45:
/Users/mos/tmp/mos_gopath/src/cesanta.com/mos/flash.go:193:
/Users/mos/tmp/mos_gopath/src/cesanta.com/mos/main.go:176: flash failed
exit status 1
Command completed.

The board is running fine under arduino firmware using platformio for flashing.

Comments

  • rodrmigurodrmigu Fairfax, Virginia

    Hi,

    I just tested with a couple fo wemos, and no issues. I often have this with esp32, I need to retry several times. Anyway, I would recommend try to lower the upload speed.

    Regards
    Rodrigo

  • I bought a batch of WROOM ESP32 devices recently and they all exhibit this problem. My previous batch, bought a few months ago worked without problem.

    My workaround is to run `mos console' in the background, and then it seems to work. No idea why that should work though.

    dan.

Sign In or Register to comment.