Copyright ©

Mongoose OS Forum

ATTENTION! This forum has moved to:

Do not post any new messages.

Build errors when building locally for CC3200

A project that built fine two days ago no longer builds locally for me.

Just to make sure I haven't messed things up I created a new empty directory and initialised a new app with the following command:
mos init -platform cc3200
then built it using the following command:
mos build --platform cc3200 --local --repo ../mongoose-os

The local repo in ../mongoose-os has been updated with git pull.

I get the same kind of error. Looking at the final parts of the build.log file I see the follwing:

GEN   /Users/ulf/Documents/Projects/mongoose/test/build/objs/boot/build_info.c recipe for target '/Users/ulf/Documents/Projects/mongoose/test/build/objs/boot/build_info.c' failed
make[1]: *** [/Users/ulf/Documents/Projects/mongoose/test/build/objs/boot/build_info.c] Segmentation fault
make[1]: Leaving directory '/mongoose-os/fw/platforms/cc3200/boot'
make: *** [/Users/ulf/Documents/Projects/mongoose/test/build/objs/boot/fw/mg-boot.bin] Error 2
/mongoose-os/fw/platforms/cc3200/ recipe for target '/Users/ulf/Documents/Projects/mongoose/test/build/objs/boot/fw/mg-boot.bin' failed
make: Leaving directory '/app'

This is the same kind of error message I get when building my on app.

Any hints on where I should look?


  • ulsoulso Stockholm

    Everything is ok when I build using the command:
    mos build --platform cc3200

    Also tried building locally for ESP32 and that worked fine as well.

  • ulsoulso Stockholm

    Just tried to build locally for CC3220. That didn't work either.

  • edited January 2018

    And what if you try totally clean build: remove ~/.mos, and build like mos build --platform cc3200 --clean --verbose? Please paste full log if it still doesn't work.

    Thanked by 1ulso
  • ulsoulso Stockholm

    I tried that yesterday, to remove everything and it didn't help.

    Just a minute ago the build finally succeeded!

    After I opened the Docker Preferences, selected Reset and "Remove all data", everything now seems fine again. Weird.

    So, right now I consider this problem fixed.

Sign In or Register to comment.