Copyright ©

Mongoose OS Forum

ATTENTION! This forum has moved to:

Do not post any new messages.

mos flashing leaves DTR and RTS low on linux


I am testing my ESP-WROOM32 based board, using a CP2102 USB UART with RTS and DTR control lines connected to EN and BOOT respectively.

On windows I can use mos to flash the module and the new firmware starts up and I can see the log messages etc.

On my kubuntu 17.04 VM it flashes OK but does not start up. The problem seems to be that the linux version of the tool leaves the DTR and RTS lines pulled low. This holds the module in reset. On windows the lines are released and go high.

The Espressif esptool works OK with the same board and the same USB UART on linux (make flash, make monitor etc).

I believe most development boards have an extra circuit to convert the "both lines low" state to "both lines high" so that it all works OK on these. See e.g.

But my board does not have the circuit, it was not needed before.




  • rojerrojer Dublin, Ireland

    the behavior of flow control pins on port open and close is highly driver-dependent. mos does raise both at the end of the flashing operation - the last thing we do is call ROMClient.BootFirmware which releases both. but there's no telling what happens when the port is closed, it varies from driver to driver.

  • OK, thanks, it now appears that if I run "mos flash" on its own it works fine.

    It is when I run the mos tool as a web server that the lines are held low (so there is no communication, whether or not flashing is attempted). So my report is misleading, sorry! It is the server mode that holds the lines low.


    MOS FLASH - flashes OK:

    MOS SERVER MODE - no connect, lines held low:

Sign In or Register to comment.