Copyright ©

Mongoose OS Forum

ATTENTION! This forum has moved to:

Do not post any new messages.

Mongoose OS Web IDE missing

edited March 2019 in Mongoose OS

Hi, when I start mos on my mac terminal it opens the mos command line tool but not the web ui.
I can however open but this only opens the command line tool in the browser.
How do I get to the full web IDE? Did something change in this new version and it is not possible anymore to access the ide?
I could not find anything in the quickstart guide, which also shows just the command line tool. Only some youtube videos showing how the full web IDE starts when running mos from the command line. But not in my case.

Some links in the quicktart guide seem to be broken or something changed. I get missing and can only navigate through the left menu.
Also this link is not working which I found in this forum here.

My mos version is 1.21.1

I also tried to use mos 1.18 but the same happens when I run mos. No web ide.


  • I have to clarify the version. I use 2.12.1. Here are the steps I used to install mongoose os as described here:

    brew tap cesanta/mos
    brew install mos

    I also tried it using curl:

    curl -fsSL | /bin/bash
    Installing from Homebrew...
    Updating Homebrew...
    ==> Auto-updated Homebrew!
    Updated 2 taps (homebrew/cask and caskroom/cask).
    No changes to formulae.

    Warning: cesanta/mos/mos 2.12.1 is already installed and up-to-date
    To reinstall 2.12.1, run brew reinstall mos
    The Mongoose OS command line tool
    Version: 2.12.1
    Build ID: 2.12.1~brew
    Update channel: release

    Installing worked fine thought in the first place and I can execute mos which brings up no browser but the application shown in the setup guide.

    How do I get to the web IDE that is praised in the youtube videos?

    I also tried running the windows mos.exe but with the same result.

    Was the web ui removed? If so, why? Could you please add a hint in the setup or below the videos that clarifies the missing web ui in newer versions if that is the case?

  • fjpfjp
    edited March 2019

    Ok, I found the answer in this post.
    The ide was removed in the release tag 2.7.0. I will try running 2.6.0 as suggested in the post.

    I think it would be helpful to add this info about the update somewhere in the setup guide or on the github page.
    Because everything I found in the beginning seemed to be using the web IDE and not Visual Studio Code.
    What was the reason to remove the web ide? It seemed to work great.

  • nliviunliviu Romania

    The current docs

Sign In or Register to comment.