Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Failed to resolve server for dashboard

I am running a set of Mongoose ESP32 IOT devices on various different community buildings. One site repeatedly fails to be able to resolve DNS addresses. For example:

mg_resolve_async_eh Failed to resolve 'dash.mongoose-os.com', server 8.8.8.8

When I first tried to debug this this problem at the site the device was using the WiFi's' advertised DNS server, so I explicitly overrode it setting the configuration option wifi.sta.nameserve to Google's public DNS server, but as the message above shows, that didn't help. I turned the debug level up, and it didn't give any further information of what was failing. I've tried several other devices (e.g., laptops, mobile)on that WiFi network and they have no problems, so there appears to be something different going on Mongoose.

Is there anything further I can do to troubleshoot why the DNS is failing to resolve?

thanks,

dan.

Sign In or Register to comment.