Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

Can't disable RPC mechanism over websockets

Hi,

I am trying to disable rpc mechanism over websockets. The configuration setting rpc.ws.enable=false does not work. I am able to turn off the rpc mechanism all together by setting rpc.enable=false but I need to access the rpc mechanism of the device over MQTT. Any help in this regard will be appreciated.

Faizan

Comments

  • Tested with 2.8.1 and latest and I can't reproduce your issue.

  • I am also trying with the latest version, 2.8.1

    Here is the screenshot. You can see that rpc.ws.enable key is set to false, yet the http rpc call is successful.

Sign In or Register to comment.