Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

Local Build Failure -- Docker Toolbox -- Makefile.build: No such file or directory

NickNick Los Angeles, CA
edited November 2018 in Mongoose OS

Hey all. I've been trying to get my local build operational so I can debug a core dump, but I keep hitting a snag. This is the command I'm running:

mos build --local --verbose --platform esp32 --repo /mongoose-os --clean

This is the result:

Docker arguments: run --name mos_build_2018-11-09T19-06-49-00_1814374070 --rm -i -v /c/mos/app1/app/deps/spi/src:/c/mos/app1/app/deps/spi/src [... redacted for brevity]
make: Entering directory '/app/app'
make: /mongoose-os/fw/platforms/esp32/Makefile.build: No such file or directory
make: Leaving directory '/app/app'
make: *** No rule to make target '/mongoose-os/fw/platforms/esp32/Makefile.build'.  Stop.
Error: exit status 2

I found a thread with a similar error here, but it seemed to end without a definite solution. Something was mentioned about shared folders in VirtualBox, but it wasn't clear and I've not had any success messing with shared folders so far.

I have the repo cloned to C:\mongoose-os. I've tried various combinations of --repo with and without the C:\ prefix to no avail.

This is Windows 10 Home edition (hence the usage of Docker Toolbox.) Any ideas?

Comments

  • SergeySergey Dublin, Ireland

    It looks like the mentioned thread indeed indicated a definite solution

  • NickNick Los Angeles, CA

    @Sergey I fear I must be overlooking something obvious then. When I try to add /z as a shared folder it switches it to \z and grays out the "OK" button as it not being a valid folder:

  • NickNick Los Angeles, CA

    Any thoughts on this? It's rather difficult to debug a hard-crash without being able to load the core dump.

  • edited January 25

    @Nick I am facing the exact same problem as you mentioned with the shared folder. I am trying to local build using Docker toolbox on windows 10. Did you find any solution to this?
    @nliviu can you help us on this?

  • nliviunliviu Romania

    @sumedhburbure Your application is in E:\InfiPlus\atoi and the E: drive is not shared with Virtual Box.

  • edited January 25

    @nliviu Apologies for the silly mistake. I have kept the Virtual Box shared folder settings unchanged and tried to local build the default mjs example which is in my C drive. I am still getting the same error "No rule to make target"

  • nliviunliviu Romania

    Now your application is in C:\mos. Did your share C: with Virtual Box?

  • edited January 25

    Yes I did now and tried to local build again but facing the same problem :( . The problem appears the same even if I just keep C:/ Drive on shared folder in the Virtual Box and remove the C:/Users/z or vice versa.

  • nliviunliviu Romania

    Try /c/ instead of C_DRIVE. It works for me on Windows 7.

    Thanked by 1sumedhburbure
  • The problem was the path defination in the shared folder of virtual box. You are right. However, for me (Windows 10 Home) , only '/c' worked and local build was successful . Thanks @nliviu , without your hint I wouldn't be able to address the problem :)

Sign In or Register to comment.