Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

AWS IoT walkthrough doesn't match what appear in mos web console

acoulsonacoulson Texas
edited August 3 in Mongoose OS

I am trying to walk through an example of connecting and esp8266 or esp32 to AWS IoT, but none of the video walkthroughs seem to match what is presented by the console web GUI (I am using the windows version of mos.exe and it indicates version:2.4.3).

One video shows a wizard which has 4 steps, the last of which prompt for which cloud you want to connect to. I see nothing like this at all.

A completely different set of instructions here: https://mongoose-os.com/aws-iot-starter-kit/#dev is closer, and the video shows a panel which is much closer to what I see than the wizard, but the directions still don't match - for example, there is no "mos-esp32-latest" firmware, just an "esp32" - and the video on that page shows "AWS Region" and "AWS Policy" settings under Device Config that I definitely don't see. I have "Access Key ID" and "Secret Access Key". I'd like the process illustrated in the video where a certificate is generated and downloaded, but that doesn't seem to be what's happening in the console that is being presented to me.

Is there a version mismatch here? Does windows version 2.4.3 of mos.exe support the certificate download? Is there a more up-to-date mos version or video that I should be looking at? These inconsistencies are all very confusing.

Comments

  • nliviunliviu Romania

    The video you are referring to is very outdated (2017).
    Read Mongoose OS + AWS IoT

  • I got through it more or less following the second set of instructions, but just had to put my AWS access key and secret in first and click save, after which the prompt for which Region and Policy to use appeared. After that, it more or less worked. One strange thing though, I first ran through the exercise using an ESP32, then switched to an ESP8266. Following the steps on subsequent tries kept creating a thing with an "ESP32_xxxxxx" name (the first one). I finally had to edit and save a "conf9.json" file that contained the device id and that finally worked.

  • I take it back - it never created the thing with a "ESP8266_xxxxx" name, it's always esp32_818C6C

Sign In or Register to comment.