Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Error when flashing to cc3220SF

kbapatkbapat Gainesville

Hello everyone, I am trying to flash the demo-js app to my cc3220SF launchpad, but every time it ends with a flashing error. Following is the log:

Error: failed to load https://mongoose-os.com/downloads/api.json
[Jul 8 10:36:08.045] E0708 10:36:08.044036 412 ui.go:539] Calling: Sys.GetInfo
[Jul 8 10:36:11.381] E0708 10:36:11.381071 412 ui.go:563] Call complete, error: context deadline exceeded
[Jul 8 10:36:25.756] Fetching https://github.com/mongoose-os-apps/demo-js/releases/download/2.3/demo-js-cc3220.zip...
[Jul 8 10:36:32.569] Loaded demo-js/cc3220 version 1.0 (20180615-171230/???)
[Jul 8 10:36:34.296] Found BPI binary: c:\ti\uniflash_4.3.1\simplelink\imagecreator\bin\BuildProgrammingImage.exe
[Jul 8 10:36:34.296] Using XDS110 debug probe to control the device...
[Jul 8 10:36:34.326] XDS110 2.3.0.20 HW 39 S/N E0071009
[Jul 8 10:36:34.327] Opening COM6...
[Jul 8 10:36:34.327] Connecting to boot loader..
[Jul 8 10:36:35.468] CC3220SF boot loader v0.1.0.3, storage 0x86
[Jul 8 10:36:35.469] Switching to NWP...
[Jul 8 10:36:36.733] NWP boot loader v1.1.0.3, storage 0x84
[Jul 8 10:36:36.748] MAC: 98:84:e3:f6:70:2f
[Jul 8 10:36:36.748] Applying boot loader patches...
[Jul 8 10:36:37.133] RAM patch applied, new version: 1.1.0.34
[Jul 8 10:36:37.518] Flash patch applied
[Jul 8 10:36:37.518] Generating UCF image for 98:84:e3:f6:70:2f (flash size: 4194304)
[Jul 8 10:36:37.544] Running c:\ti\uniflash_4.3.1\simplelink\imagecreator\bin\BuildProgrammingImage.exe -i C:\Users\kaust\AppData\Local\Temp\demo-js_cc3220_1.0_086248199 -x C:\Users\kaust\AppData\Local\Temp\demo-js_cc3220_1.0_086248199\ImageConfig.xml
[Jul 8 10:36:44.379] Uploading UCF image (731024 bytes)
Flashing error: failed to upload image: image programming error @ 0: e0 = -10275, e1 = 4097

I am using the latest release mos version 2.3, and I am not able to figure out the problem here. I have also tried the same in Ubuntu 16.04 (VM), but it gives the same error. I am able to flash other firmware code(TI-RTOS/FreeRTOS) to the controller using either CCS or Uniflash, but I am facing problem with mongoose-os apps. Can anyone please tell me if I am missing out something and what I should be doing to troubleshoot this error?

Thanks,
Kaustubh

Comments

Sign In or Register to comment.