Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Troubleshooting request (formatted in How to Ask Questions)

desnotesdesnotes Spring Hill, FL

My Goal: How to get one (possibly two) ESP32 HUZZAH32 Feathers to connect to Mongoose OS and upload firmware to them.

I plugged in a just received Adafruit ESP32 HUZZAH32 Feather to a known good USB cable to a HP Laptop running just installed Ubuntu 18.04 LTS. Steps taken were to select the correct address, /dev/ttyUSB0, which was included in the drop-down selection. The next step was to press the press the 'Select' button. The result I expected was the device would connect and I would be able to select the 'Platform,' 'App,' and WiFi credentials.

The actual result after selecting the correct address was the device did not connect when I clicked on the 'Select' button. I tried the following items:

  • Resetting the device
  • Checking that cable is, in fact, a USB data cable.
  • Downloaded and installed USB drivers for Linux
  • Exchanged devices and tried a new devices (both ESP32 & ESP3266)
  • Previously asked for help on forum (wrong format).
  • Previously asked for help on chat.

Any help would be appreciated. If it turns out this has never happened before and no one has any ideas, that would be helpful also.

Thanks,

desnotes

Sign In or Register to comment.