Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

HTTP in device config

Hello people,

this is my first post in the forum , please forgive if I am re-posting but I am unable to find solution to this on either Google search or on this forum.

my problem is : my default empty app for ESP8266 does not have HTTP enabled in config , it doesnt have HTTP json node in any of the Conf.json files. now to enable web interface or websockets,

even if I am changing config file and saving it either by MOS webUI or using a windows File Explorer and notepad++ combo , still the config file gets overwritten and the HTTP is not there .

has anyone else faced same issue and can point me in the right direction ?

Comments

  • nliviunliviu Romania

    Add - https://github.com/mongoose-os-libs/http-server in the libs section of mos.yml, build and flash.

  • edited May 2018

    Thanks for quick reply , but it still does not work..

  • nliviunliviu Romania

    Did you re-build and flash after modifying mos.yml?

  • Thanks Nliviu, surprisingly after 2 cycles of build - flash - reboot , it is now working.. thanks a lot.. does it mean that I have to add lib reference for anything that I want to change in Conf ?

  • nliviunliviu Romania
    edited May 2018

    If you need a feature provided by a Mongoose OS library, you have to add and configure it in mos.yml.

Sign In or Register to comment.