Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Build fails complaining regarding certificate!?!!

Does anyone have any clue?

When I issue build command, I get the following error.

mos build --arch esp32

Connecting to https://mongoose.cloud, user test
Uploading sources (17403 bytes)
Error: Post https://mongoose.cloud/api/fwbuild/1.26/build: x509: certificate signed by unknown authority

Thanks,

Mohammad

Comments

  • If I try to do a local build it still fails:

    Please noote: I have obfuscated my local project dir.

    Error: preparing local copy of the lib "wifi": cloning "https://github.com/mongoose-os-libs/wifi" to "/Users/XXXXXXXXXXXXXXXXXXXX/deps/wifi": Get https://github.com/mongoose-os-libs/wifi/info/refs?service=git-upload-pack: x509: certificate signed by unknown authority

  • SergeySergey Dublin, Ireland

    Works well for me:

    $ mos build --arch esp32
    Connecting to https://mongoose.cloud, user test
    Uploading sources (1432 bytes)
    Firmware saved to build/fw.zip
    
  • Ok, things are working for me now. It seems that problem was on my end.

    My environment:

    mohammadbhuyan$ sw_vers
    ProductName:    Mac OS X
    ProductVersion: 10.13.3
    BuildVersion:   17D102
    
    mos --version
    The Mongoose OS command line tool
    Version: 1.26
    Build ID: 20180208-184624/1.26@ab7f50e1+
    Update channel: release
    

    Afte a restart it started working. So I have no clue what was wrong.

    Usually, my mac uptime is quite long. But recently I had a file system crash. I tried reboot because I was desperate. :persevere:? Only, mentionable event before the problem was I upgraded installed docker. I don't think that has any impact on the cloud build.

    So, the conclusion is atm,

    • I don't know what caused it
    • A restart got it back to work, so, I don't know what fixed it.
Sign In or Register to comment.