Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

Flash size

Hi, I've tested the Beta2 fw with NodeMCU board 4MB and I think there's a lot of great improvements in fw and also in fnc .
Nice work!
Now I'm trying to use a ESP8266-01 module but I now fw need more than 2MB of flash. I have change the flash with 2MB with another flash. This one is 8MB. I've tried to flash with fnc but give me always error. So I've used esptool and flash succesfully.
But some function of fnc seems don't work properly. If I try to reboot from fnc button give me:

UNAVAILABLE: failed to communicate to ROM: ESPROMClient::connect(): SLIP::recv(ttyUSB0, 200): no data 1: Operation timed out

but if I put RST to ground make the correct reboot.

The fw it's ok, the AP start, I can connect,I can upload.

other question: 

what's the meaning of

[[Circular]]


thank you,
Andrea

Comments

  • adminadmin Dublin, Ireland
    1. The meaning of "circular" is that the object it's referring to creates a circular dependency, so it is impossible to print it.
    2. Let us follow up on the FNC question shortly.
  • rojerrojer Dublin, Ireland
    edited February 2016
    "if I put RST to ground make the correct reboot" - with RST tied to GND ESP8266 will be in reset and not communicate at all.
    with ESP-01 you need to put the device into boot loader mode manually: connect GPIO0 to GND and reset the device by briefly touching RST to GND. after this, you should be able to flash (pressing "flash" in fnc will work). however, after flashing you will need to reboot the device manually into firmware (by touching RST to GND again).
    is that what you see?
  • Sorry, perhaps I expressed myself badly.
    when I use nodeMCU board and I push the reboot button of fnc I obtain a reboot( software side?), if I push the RST button on the board I make a reset pulling down the reset pin of the chip, then a reboot. The result on the serial monitor it's the same, some garbage and all the start information.
    I have used my custom esp8266-01 with a 8MB flash.
     Like other ESP 01 , after pulling down gpio 0 , it's necessary touch RST to GND to flash, but with my custom 01 and beta2 and last fnc I'm unable to flash.
    I can flash with esptool and after flash I use fnc to comunicate, but with 8MB flash give me the error described in this post when I use the reboot button of fnc. If I touch RST to GND during a connection I obtain a reboot without error.
    this is what I see , I hope I have expressed myself better!!
    thanks 
  • I've tried to flash one ESP12 and my custom 01 with 8M flash and give me the same error : 

    UNAVAILABLE: failed to communicate to ROM: ESPROMClient::connect(): SLIP::recv(ttyUSB0, 200): no data 1: Operation timed out

    with nodeMCU board I can flash, boot and reboot with no problem . 
    I got some doubt about the quality of my esp12 but my 01 custom work  correctly if I use other fw. Maybe the flash ?
  • rojerrojer Dublin, Ireland
    are your RST and GPIO0 wired correctly? they should be connected to RTS and DTR respectively - or you need to fiddle with them manually to put ESP into bootloader first.
  • Hi,  maybe the problem is the RTS and DTR, with the same wiring and esptool flash succesfully . I will try.
    thanks a lot.
  • I think another things: I'm able to put ESP in flash mode and I reset the chip before flashing to flash correctly with esptool. If I use esptool with DTR and RTS do the 'pre-flash' by itself. Maybe fnc need always the DTR and RTS wired and don't let me put the chip in flash mode manually?
  • rojerrojer Dublin, Ireland
    FNC should pop up a dialog every time it fails to talk to bootloader - "i can't talk to bootloader, please put your device into flashing mode and press retry". this way, you should be able to flash with just TX and RX connected (manually fiddling with rst and gpio and pressing retry on every flash). the dialog was broken (did not show) on version 0.8, this was fixed in 0.8.1
    do you see the dialog?
  • Hi rojer, I've tried also the 0.8.1 under Debian but if I use a ESP12 module and not a NodeMCU board I find a lot of problem.
    With a 'custom board' I've connected aFTDI FT232RL with DTR and RTS like you explain and like here is explained
    https://github.com/cesanta/smart.js/blob/master/smartjs/platforms/esp8266/flashing.md
    but I receive this error

    and when flash succesfully I'm not able to connect and most time the blue led on esp stay on and the tx-rx led of the FTDI flash cotinuosly and I lose the serial.

    I've tried to flash with esptool with DTR and RTS:

    flash succesfully and I'm able to connect, but when connected , sometimes return me :

    chg_A3:-180

    I need to reboot manually also with RTS connected.

    with the NodeMCU board I don't have this problem, but I don't understand how fnc can use RTS and DTR via USB!

    I need to resolve because We are build a project with Smart.js on ESP and We need to flash succesfully without problems a lot of device. We are in test but We need a secure flash with ESP without the NodeMCU board that I have used to test.

    thank you.



  • Ok , I've check the schematics and I understand how CP2102 or other serial converter take care of the DTR and RTS.
    I've tried other 2 serial converter ( CP2102 and CH340) , I see that sometimes ( but not always) I can flash succesfully with fnc putting the chip in flash mode manually, but often I lose the serial, the serial port disappear and I can't comunicate. 
    But I can see the AP( not always).
    now I'm in doubt if is an hardware problem , but i've tried a lot of cable, converter, connection .
    have you ever tried a esp12 non nodeMCU board?
  • rojerrojer Dublin, Ireland
    yes, i flash ESP-12 with FTDI adapters all the time.
    CH340 is the converter used on NodeMCU 0.9 board and that works fine too.

    simply connect RTS to the RST pin (easy to remember: RTS -> RST) and DTR to GPIO0. that's all.
Sign In or Register to comment.