Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

mos build fails

I was working with a project and made a change which should have worked.
I decided to build the init project and go from there. I'm using Ubuntu 16.04 and mos is installed via the PPA and apt.
Here is what I am doing in an empty directory:

mos init --arch=esp32
Downloading empty app...
Unpacking...
Setting arch "esp32"...

ls
fs mos.yml README.md src

So the empty project is downloading successfully. So next try building it:

mos build
Error: preparing local copy of the lib "ca-bundle": failed to git checkout 1.14: error: pathspec '1.14' did not match any file(s) known to git.
exit status 1

The build appears to fail, however, the directory structure is different:

ls
build fs mos.yml README.md src

In the build directory there is one file with name build.log. The contents:

cat build.log
Handling lib "ca-bundle"...
The --lib flag was not given for it, checking repository

I thought maybe something on my machine was corrupted, so I did an install on a machine which had Mongoose-os installed.
Exact same thing happened. Also I tried the binary, and this showed the same problem.
Has something changed or am I doing something wrong?

Regards,
Greg

Comments

Sign In or Register to comment.