Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Disable Brownout Detector on ESP32

Is there a way to disable the brownout detector on the ESP32?

Comments

  • rojerrojer Dublin, Ireland

    try this:

    build_vars:
      ESP_IDF_SDKCONFIG_OPTS: "${build_vars.ESP_IDF_SDKCONFIG_OPTS} CONFIG_BROWNOUT_DET="
    

    this adds CONFIG_BROWNOUT_DET= to IDF's sdkconfig.

  • I have tried inserting the above, copy and paste, into the mos.yml file. The project fails to build:

    mos --arch=esp32 build
    Connecting to https://mongoose.cloud, user test
    Uploading sources (1365 bytes)
    Handling lib "rpc-service-config"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/rpc-service-config-1.14"
    Handling lib "rpc-common"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/rpc-common-1.14"
    Handling lib "http-server"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/http-server-1.14"
    Handling lib "rpc-service-fs"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/rpc-service-fs-1.14"
    Handling lib "rpc-common"...
    Already handled, skipping
    Handling lib "rpc-uart"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/rpc-uart-1.14"
    Handling lib "rpc-common"...
    Already handled, skipping
    Handling lib "wifi"...
    The --lib flag was not given for it, checking repository
    Prepared local dir: "/fwbuild-volumes/1.14/apps/my-app/esp32/build_contexts/build_ctx_941862299/libs/wifi-1.14"
    Error: failed to evaluate build_vars.ESP_IDF_SDKCONFIG_OPTS
    Error: build failed

    Here is a snippet of what I did to the mos.yml file:

    ...

    List of dirs. Files from these dirs will be copied to the device filesystem

    filesystem:
    - fs

    build_vars:
    ESP_IDF_SDKCONFIG_OPTS: "${build_vars.ESP_IDF_SDKCONFIG_OPTS} CONFIG_BROWNOUT_DET="

    Custom configuration entries, settable via "device configuration"

    Below is a custom firmware configuration example.

    Uncomment and modify according to your needs:

    ...

    The above was inserted into the mos.yml file for the empty-project.

    Am I supposed to set an environment variable prior to mos build???
    I am trying to activate ESP32 dual-core. The default build is FreeRTOS on core 0 only.

    Regards,
    Greg

  • I am having trouble implementing build_vars. I am trying to change CONFIG_ESP32_DEEP_SLEEP_WAKEUP_DELAY by adding the following line to a "build-vars:" section of my mos.yml file: ESP_IDF_SDKCONFIG_OPTS: "${build_vars.ESP_IDF_SDKCONFIG_OPTS} CONFIG_ESP32_DEEP_SLEEP_WAKEUP_DELAY=2000", but the deep sleep wakeup delay does not change. What am I doing wrong? How can I can change ESP32 SDKCONFIG options in Mongoose?

  • SOLVED. See solution posted here: https://forum.mongoose-os.com/discussion/1543

    It came down to where, and how many, blank spaces are inserted in the "ESP_IDF_SDKCONFIG..." string.

Sign In or Register to comment.