Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Linking errors with "#define MG_ENABLE_SSL"

I'm having issues compiling my VC++ Mongoose 6.5 project with the "#define MG_ENABLE_SSL" flag. I get the following errors:

1>libeay32MT.lib(md5_dgst.obj) : error LNK2005: _MD5_Final already defined in mongoose.obj
1>libeay32MT.lib(md5_dgst.obj) : error LNK2005: _MD5_Init already defined in mongoose.obj
1>libeay32MT.lib(md5_dgst.obj) : error LNK2005: _MD5_Update already defined in mongoose.obj

Am I linking to the wrong library? Everything compiles fine without the MG_ENABLE_SSL flag.

Comments

Sign In or Register to comment.