Copyright © https://mongoose-os.com

Mongoose OS Forum

frame
ATTENTION! This forum has moved to:

https://community.mongoose-os.com

Do not post any new messages.

mos tool crashy on ubuntu 17.04

Hi

I am getting continual crashes of the mos tool for anything much more complicated than launching the browser interface. For example building fails with a lot of go errors, and e.g. "mos init" fails 3 times out of 4.

This is on a Kubuntu 17.04 64bit VM

Any suggestions?

Thanks,
John Devereux

```

Comments

  • Hi, thanks for the response.
    "mos init" now seems to work.
    The mos tool "web server" mode no longer dumps error messages to the linux terminal but something similar seems to happen in the server log (i.e. in the browser window). See attached error log.
    (It mentions bad build ID, it was a "bad build ID" that stopped me compiling the tool from source when I tried).
    Thanks
    John

  • rojerrojer Dublin, Ireland

    please update, a new package was pushed with a fix for that

  • That was fast, 8 minutes... and it works, thanks!

  • rojerrojer Dublin, Ireland

    it was actually earlier. this problem was independently discovered by myself a bit earlier. when, you know, i actually tried to use the thing :)
    but hopefully now it's all smooth sailing from here. i'm dogfooding it, which is to say using day to day, so updates will be regular.

Sign In or Register to comment.