Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

build error

z_X_zz_X_z Poland
edited May 17 in Mongoose OS

Hello yesterday all worked after the update mos.exe in window 7 error.

$ mos build
Connecting to http://mongoose.cloud, user test
Uploading sources (99433 bytes)
The flag --repo is not given, going to use mongoose-os repository
Repository "/root/.mos/modules/mongoose-os" does not exist, cloning...
Sources: [src/*.c src/*.cpp]
Building...
Docker arguments: run --rm -i -v /tmp/fwbuild-volumes/users/test/c_http/build_requests/build_req_827982603:/app -v /root/.mos/modules/mongoose-os:/mongoose-os -v /root/.mos/modules/mongoose-os:/root/.mos/modules/mongoose-os -v /tmp/fwbuild-volumes/users/test/c_http/build_requests/build_req_827982603/src:/tmp/fwbuild-volumes/users/test/c_http/build_requests/build_req_827982603/src -v /tmp/fwbuild-volumes/users/test/c_http/build_requests/build_req_827982603/fs:/tmp/fwbuild-volumes/users/test/c_http/build_requests/build_req_827982603/fs --user 0:0 docker.cesanta.com/esp8266-build:2.0.0-1.5.0-r4 /bin/bash -c nice make '-j' '16' '-C' '/app' '-f' '/mongoose-os/fw/platforms/esp8266/Makefile.build' 'APP_SOURCES=src/*.c src/*.cpp' 'APP_CONF_SCHEMA=src/conf_schema.yaml' 'APP_VERSION=1.0' 'FFI_SYMBOLS=' 'BUILD_DIR=build/objs' 'FW_DIR=build/fw' 'FS_STAGING_DIR=build/fs' 'APP=c_http' 'APP_FS_FILES=fs/*' 'GEN_DIR=build/gen' 'MGOS_PATH=/mongoose-os' 'PLATFORM=esp8266'
make: Entering directory '/app'
make: /mongoose-os/fw/platforms/esp8266/Makefile.build: No such file or directory
make: Leaving directory '/app'
make: *** No rule to make target '/mongoose-os/fw/platforms/esp8266/Makefile.build'.  Stop.
Error: exit status 2
Error: build failed

Comments

Sign In or Register to comment.