Copyright © https://mongoose-os.com

Mongoose OS Forum

frame

Change name of AWS IoT thing

martwanamartwana United Kingdom

Good Evening

I have Mongoose OS running on my sonoff adapters - very well I must say. They are paired up with AWS IoT Shadows, allowing me to easily control them.

I was able to sync up with AWS no problem using the Web GUI for one adapter, and the CLI for the other. One thing I noticed is the device name is set to esp8266_3C113E. There doesn't seem to be any way to change this from within AWS.

I tried changing the device->id in the config file, and also aws->shadow->thing_name, but neither seem to have any effect.

Is there a way to change the name of the thing?

M

Comments

  • rojerrojer Dublin, Ireland

    both of these should definitely work. aws.thing_name has priority over device.id, so if you set that, it should be used as thing name.
    but i recommend that you change device.id, so everything is in sync (device id is also used e.g. for rpc topic names, logging, etc)
    please post device's boot log after changing the setting.

  • martwanamartwana United Kingdom

    So I set both those, but it doesnt seem to show in the AWS IoT dashboard.

    BUT!

    Since I asked the question, I built a Lambda + API Gateway tool that will trigger the sonoff's, by the device name - and it does work.

    I'll put this down to the AWS IoT dashboard being stupid.

  • martwanamartwana United Kingdom

    Thanks for your reply!

  • rojerrojer Dublin, Ireland

    ah, well. changing IOT thing name will not create it. the thing is created during aws-iot-setup process by the mos tool.
    so, you can either repeat that with a different --aws-iot-thing=MYTHING or manually create it from the dashboard and then config-set the device.id (as you already did, the order doesn't really matter).

  • martwanamartwana United Kingdom

    AH!

    That was the key there --aws-iot-thing

    That doesnt seem to be well documented. That did it for me. Thanks a bunch

  • rojerrojer Dublin, Ireland

    yeah, documentation is a bit behind, as always :)

Sign In or Register to comment.